User Tools

Site Tools


neuroelf_gui_-_menu_tree

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
neuroelf_gui_-_menu_tree [2011/04/14 02:53]
jochen repaired link to spm5_preprojobs
neuroelf_gui_-_menu_tree [2011/12/08 23:28] (current)
jochen added MKDA to the list
Line 12: Line 12:
 ===== File menu ===== ===== File menu =====
   * **Open...** - opens a file selector for all major formats available for visualization,​ both anatomical/​functional (VMR, MSK, HDR/NII, HEAD, VTC, FMR, DMR,and also SRF) as well as statistical (VMP, GLM, HDR/NII, HEAD, CMP/ICA, as well as SMP) will be listed by default; if the filetype selector (type restriction on displayed items) is changed, this selection will be remembered, additionally NeuroElf changes the current working directory (Matlab'​s ''​pwd''​) to the folder that contains the file that is being opened   * **Open...** - opens a file selector for all major formats available for visualization,​ both anatomical/​functional (VMR, MSK, HDR/NII, HEAD, VTC, FMR, DMR,and also SRF) as well as statistical (VMP, GLM, HDR/NII, HEAD, CMP/ICA, as well as SMP) will be listed by default; if the filetype selector (type restriction on displayed items) is changed, this selection will be remembered, additionally NeuroElf changes the current working directory (Matlab'​s ''​pwd''​) to the folder that contains the file that is being opened
 +  * **Select current object** - a sub-menu populated with all loaded (voxel-based) anatomical objects (**only visible when the GUI is in [[NeuroElf GUI#​minimized_mode|minimized mode]]**)
   * **Recently loaded slicing objects** - a sub-menu populated with anatomical (voxel-based) files that were recently opened (only if opened via the GUI and file selection dialog, not via a script or ''​object.Browse;''​ call; this information is stored in the configuration file under section [''​RecentFiles''​],​ setting ''​SliceVar''​)   * **Recently loaded slicing objects** - a sub-menu populated with anatomical (voxel-based) files that were recently opened (only if opened via the GUI and file selection dialog, not via a script or ''​object.Browse;''​ call; this information is stored in the configuration file under section [''​RecentFiles''​],​ setting ''​SliceVar''​)
   * **Recently loaded slicing stats objects** - a sub-menu populated with statistical (voxel-based) files that were recently opened (stored in setting ''​StatsVar''​)   * **Recently loaded slicing stats objects** - a sub-menu populated with statistical (voxel-based) files that were recently opened (stored in setting ''​StatsVar''​)
   * **Recently loaded surface objects** - a sub-menu populated with surface files that were recently opened (stored in setting ''​SurfVar''​)   * **Recently loaded surface objects** - a sub-menu populated with surface files that were recently opened (stored in setting ''​SurfVar''​)
   * **Recently loaded surface stats objects** - a sub-menu populated with surface-based statistics files that were recently opened (stored in setting ''​SurfStatsVar''​)   * **Recently loaded surface stats objects** - a sub-menu populated with surface-based statistics files that were recently opened (stored in setting ''​SurfStatsVar''​)
 +  * **Colin-27 dataset** - a sub-menu populated with the files found in the ''​_files/​colin/''​ sub-folder of the NeuroElf installation folder (in two sub-menus: **VMRs** and **Surfaces**)
   * **Clone slicing object** - creates a copy of the currently selected slicing (voxel-based anatomical or functional) object, e.g. to allow painting into the object with the ability to compare "​before"​ and "​after"​ stages; this **does not** copy the filename association (and thus, the object requires to be "saved as..."​)   * **Clone slicing object** - creates a copy of the currently selected slicing (voxel-based anatomical or functional) object, e.g. to allow painting into the object with the ability to compare "​before"​ and "​after"​ stages; this **does not** copy the filename association (and thus, the object requires to be "saved as..."​)
 +  * **New slicing object (empty VMR)** - creates a new (all-blank/​empty) VMR, which can be used as the starting point of a segmentation (using the Underlay feature, which then also works with other object types); importantly,​ **the new VMR has to be saved to allow reload from disk!**
   * **Reload slicing object** - reloads the content of the currently selected slicing object from disk (only functional if the object has been loaded or saved before and a filename associated with it)   * **Reload slicing object** - reloads the content of the currently selected slicing object from disk (only functional if the object has been loaded or saved before and a filename associated with it)
 +  * **Clone stats object** - creates a copy of the currently selected statistical (voxel-based) object, e.g. to allow using several beta plot windows on the same GLM data
   * **Reload stats object** - reloads the content of the currently selected (voxel-based) statistical object from disk (same restriction applies)   * **Reload stats object** - reloads the content of the currently selected (voxel-based) statistical object from disk (same restriction applies)
 +  * **Set underlay object** - sets a secondary object which is display //below// (underlaying) the current selected anatomical slicing object (the way in which the two datasets are blended can be controlled via the **File -> Options -> Underlay blending mode** sub-menu)
   * **Save** - saves (i.e. overwrites) the currently selected slicing (voxel-based anatomical or functional) object back to disk (only functional if the object has been loaded or saved before and a filename associated with it)   * **Save** - saves (i.e. overwrites) the currently selected slicing (voxel-based anatomical or functional) object back to disk (only functional if the object has been loaded or saved before and a filename associated with it)
   * **Save as...** - opens a file saving dialog (''​uiputfile''​),​ and, unless this dialog is canceled or an invalid filename is entered, stores the currently selected slicing object under the given filename (and stores this filename with the object for subsequent calls to ''​File''​ -> ''​Save''​)   * **Save as...** - opens a file saving dialog (''​uiputfile''​),​ and, unless this dialog is canceled or an invalid filename is entered, stores the currently selected slicing object under the given filename (and stores this filename with the object for subsequent calls to ''​File''​ -> ''​Save''​)
   * **Save stats** - saves (i.e. overwrites) the currently selected (voxel-based) statistical object back to disk (only functional if the object has been loaded or saved before and a filename associated with it)   * **Save stats** - saves (i.e. overwrites) the currently selected (voxel-based) statistical object back to disk (only functional if the object has been loaded or saved before and a filename associated with it)
   * **Save stats as...** - opens a file saving dialog (''​uiputfile''​),​ and, unless this dialog is canceled or an invalid filename is entered, stores the currently selected (voxel-based) statistical object under the given filename (and stores this filename with the object for subsequent calls to ''​File''​ -> ''​Save''​)   * **Save stats as...** - opens a file saving dialog (''​uiputfile''​),​ and, unless this dialog is canceled or an invalid filename is entered, stores the currently selected (voxel-based) statistical object under the given filename (and stores this filename with the object for subsequent calls to ''​File''​ -> ''​Save''​)
 +  * **Import Analyze to VMR...** - allows to select an Analyze/​NIftI image, which is then converted to [[xff - VMR format|VMR format]] using the [[importvmrfromanalyze]] function and subsequently loaded and displayed in the GUI
 +  * **Import SPM maps to VMP...** - allows to select a set of SPM-based statistic files (''​spm_Fxxxx.hdr/​nii''​ and/or ''​spm_Txxxx.hdr/​nii''​ files) which are then imported to VMP format using the [[importvmpfromspms]] function and subsequently loaded and displayed in the GUI
 +  * **Import RFX-GLM from SPM.mat files...** - opens the [[importrfxglmfromspms]] UI to import a [[xff - GLM format|RFX-GLM]] file from SPM.mat files
  
 ==== File -> Options menu ==== ==== File -> Options menu ====
Line 31: Line 39:
       * **center coordinate** - if selected (and subsequently being "​checked"​) the text output will show the average (mean) coordinate for each cluster       * **center coordinate** - if selected (and subsequently being "​checked"​) the text output will show the average (mean) coordinate for each cluster
       * **center-of-gravity** - if selected (and subsequently being "​checked"​) the text output will show a weighted average (sum of the products of absolute statistical values and coordinates divided by the sum of the absolute statistical values)\\ {{:​clustertable_option_cog.png|COG formula}}       * **center-of-gravity** - if selected (and subsequently being "​checked"​) the text output will show a weighted average (sum of the products of absolute statistical values and coordinates divided by the sum of the absolute statistical values)\\ {{:​clustertable_option_cog.png|COG formula}}
 +      * **print sub-cluster sizes** - if selected (and subsequently being "​checked"​) the text output will contain an estimate of the number of voxels also for sub-clusters (using a [[splitclustercoords#​algorithm|watershed-based algorithm]])
 +      * **sort table by stats** - if selected (and subsequently being "​checked"​) the list of clusters will be sorted by the (absolute) stats value (decending values)
 +      * **sort table by signed stats** - if selected (and subsequently being "​checked";​ this is the default) the list of clusters will first be sorted by the sign of each cluster peak and then, within positive and negative clusters, by the absolute value of the peak coordinate (descending values)
 +      * **sort table by cluster size** - if selected (and subsequently being "​checked"​) the list of clusters will be sorted by the cluster size of each cluster (decending values)
 +      * **sort table by X coordinate** - if selected (and subsequently being "​checked"​) the list of clusters will be sorted by the X coordinate of each cluster peak (decending values)
 +      * **sort table by Y coordinate** - if selected (and subsequently being "​checked"​) the list of clusters will be sorted by the Y coordinate of each cluster peak (decending values)
 +      * **sort table by Z coordinate** - if selected (and subsequently being "​checked"​) the list of clusters will be sorted by the Z coordinate of each cluster peak (decending values)
     * **Orientation** - sub-item menu with...     * **Orientation** - sub-item menu with...
       * **neurological** - if selected (and subsequently being "​checked";​ this is the default) voxel-based datasets will be shown with the left side of axial and coronal images representing the left hemisphere (left-is-left)       * **neurological** - if selected (and subsequently being "​checked";​ this is the default) voxel-based datasets will be shown with the left side of axial and coronal images representing the left hemisphere (left-is-left)
Line 39: Line 54:
     * **Stats Colors (LUT)** - a sub-menu populated with the OLT (overlay look-up table) files available in the ''​_core/​lut''​ folder of the NeuroElf installation;​ for each of the sub-entries,​ the currently selected ''​Map''​ (only functional if exactly one map is selected) will have its ''​LUTName''​ property set, followed by a call to ''​object.SetColors'',​ which will update the coloring of the map if, and only if, the map's ''​UseRGBColor''​ property is set to 0 (changeable by clicking on the ''​LUT''​ radio button on the interface)     * **Stats Colors (LUT)** - a sub-menu populated with the OLT (overlay look-up table) files available in the ''​_core/​lut''​ folder of the NeuroElf installation;​ for each of the sub-entries,​ the currently selected ''​Map''​ (only functional if exactly one map is selected) will have its ''​LUTName''​ property set, followed by a call to ''​object.SetColors'',​ which will update the coloring of the map if, and only if, the map's ''​UseRGBColor''​ property is set to 0 (changeable by clicking on the ''​LUT''​ radio button on the interface)
     * **Edit LUT palette** - allows to edit the currently selected LUT palette using the [[colorpicker]] function/UI (if 20 colors, used for VMR coloring)     * **Edit LUT palette** - allows to edit the currently selected LUT palette using the [[colorpicker]] function/UI (if 20 colors, used for VMR coloring)
 +    * **Underlay blending mode** - a sub-menu with 7 different settings on how the underlay object (if selected) is blended with the currently selected anatomical slicing object
 +      * **Overlay wins** - wherever the overlay (selected object) has a voxel color that is not all-0, this value will be display, the underlay value otherwise
 +      * **Overlay favored** - the higher the maximum RGB color value of the overlay (select object) voxel is, the more this object'​s color dominates the mix
 +      * **Overlay weighted** - the ratio of voxel colors is determined by ''​value_overlay / (value_overlay + value_underlay)''​
 +      * **Equal mixing** - voxel color values are mixed by a 50:50 ratio
 +      * **Underlay weighted** - the ratio of voxel colors is determined by ''​value_underlay / (value_overlay + value_underlay)''​
 +      * **Underlay favored** - the higher the maximum RGB color value of the underlay object voxel is, the more this object'​s color dominates the mix
 +      * **Underlay wins** - wherever the underlay object has a voxel color that is not all-0, this value will be display, the overlay (selected object) value otherwise
     * **Linked browsing with satellites** - if checked (selection of this entry checks and un-checks this item) browsing (clicking into) a voxel-based dataset will set the cursor position (current coordinate) not only in the window that is clicked into but in all available windows (main UI and satellites)     * **Linked browsing with satellites** - if checked (selection of this entry checks and un-checks this item) browsing (clicking into) a voxel-based dataset will set the cursor position (current coordinate) not only in the window that is clicked into but in all available windows (main UI and satellites)
     * **Show stats thresh bars** - if checked (selection of this entry checks and un-checks this item) a colored bar will be shown for each selected statistical map (only selected tails; and currently only implemented for voxel-based datasets, whereas if three panels are shown the bars will be on the coronal slice and if only a single panel is shown the bars will be doubled in size)     * **Show stats thresh bars** - if checked (selection of this entry checks and un-checks this item) a colored bar will be shown for each selected statistical map (only selected tails; and currently only implemented for voxel-based datasets, whereas if three panels are shown the bars will be on the coronal slice and if only a single panel is shown the bars will be doubled in size)
Line 50: Line 73:
  
   * **Border reconstruction** - the [[vmr.DBReco|VMR::​DBReco]] method will be called on the currently selected VMR object, resulting in a [[xff - SRF format|SRF]] (surface) object that will subsequently be added to the NeuroElf GUI interface; this function is only useful if the currently selected VMR has been "​segmented"​ (voxels above a certain threshold represent white matter voxels)!   * **Border reconstruction** - the [[vmr.DBReco|VMR::​DBReco]] method will be called on the currently selected VMR object, resulting in a [[xff - SRF format|SRF]] (surface) object that will subsequently be added to the NeuroElf GUI interface; this function is only useful if the currently selected VMR has been "​segmented"​ (voxels above a certain threshold represent white matter voxels)!
-  * **Load Undo-Buffer...** - choosing this entry will ask the user to select ​a (secondary) VMR, which will be loaded and its data stored ​in the currently selected VMR's ''​RunTimeVars.UndoBuffer''​ property, allowing ​to draw data from a different object into the currently selected VMR's data (using ​the "​undo-drawing"​ functionality)+  * **Clean VMR** - call the [[vmr.CleanVMR|VMR::​CleanVMR]] method ​to create ​second ​(copyof the VMR with all voxels detected as background set to 0 
 +  * **Correct inhomogeneity** - call the [[vmr.InhomogeneityCorrect|VMR::​InhomogeneityCorrect]] method, which in turn uses the [[pmbfilter]] function in 3 passes ​to auto-correct ​the inhomogeneity of the data
   * **Smooth VMR** - this opens up a small dialog box, where smoothing kernel, bounding box, as well as an optional value range can be specified; subsequently the [[aft.SmoothData3D|AFT::​SmoothData3D]] method will be called to perform the data smoothing (for now, this may require a large amount of memory, depending on the settings; this might lead to out-of-memory error conditions, particularly for 0.5mm-resolution VMRs!)   * **Smooth VMR** - this opens up a small dialog box, where smoothing kernel, bounding box, as well as an optional value range can be specified; subsequently the [[aft.SmoothData3D|AFT::​SmoothData3D]] method will be called to perform the data smoothing (for now, this may require a large amount of memory, depending on the settings; this might lead to out-of-memory error conditions, particularly for 0.5mm-resolution VMRs!)
 +  * **Load Undo-Buffer...** - choosing this entry will ask the user to select a (secondary) VMR, which will be loaded and its data stored in the currently selected VMR's ''​RunTimeVars.UndoBuffer''​ property, allowing to draw data from a different object into the currently selected VMR's data (using the "​undo-drawing"​ functionality)
 +  * **Export to Nifti** - exports the current VMR object as a [[xff - NII format|Nifti file]] without reslicing
  
 ===== VTC menu ===== ===== VTC menu =====
Line 58: Line 84:
   * **Mask with VMR** - if more than one VMR is open, a small listbox dialog (''​listdlg''​) showing the currently loaded VMRs will be shown, and the currently selected VTC will then be masked so that voxel timecourses where the VMR data is below visible threshold will be set to all-zeros   * **Mask with VMR** - if more than one VMR is open, a small listbox dialog (''​listdlg''​) showing the currently loaded VMRs will be shown, and the currently selected VTC will then be masked so that voxel timecourses where the VMR data is below visible threshold will be set to all-zeros
   * **Mean/​Standard dev. maps** - creates a VMP with two maps, one representing the mean (over time) and the other representing the standard deviation; this can be used for quick diagnostics (homogeneity as well as spatially isolated temporal outliers)   * **Mean/​Standard dev. maps** - creates a VMP with two maps, one representing the mean (over time) and the other representing the standard deviation; this can be used for quick diagnostics (homogeneity as well as spatially isolated temporal outliers)
 +  * **Export to Nifti** - exports the current VTC object as a [[xff - NII format|Nifti file]] without reslicing
  
 ===== GLM menu ===== ===== GLM menu =====
Line 65: Line 92:
   * **Generate MDM...** - using the references in the GLM object, an [[xff - MDM format|MDM]] is created, for which a file saving dialog is then presented; this allows to re-compute statistics with different settings in case the original MDM is not available   * **Generate MDM...** - using the references in the GLM object, an [[xff - MDM format|MDM]] is created, for which a file saving dialog is then presented; this allows to re-compute statistics with different settings in case the original MDM is not available
   * **Mask with VMR** - applies the currently selected VMR (and thus only works if the selected slicing object is of type VMR!) as a mask to the GLM in a way that, for all maps in the GLM object, voxels where the VMR data is below the visibility threshold will be set to 0   * **Mask with VMR** - applies the currently selected VMR (and thus only works if the selected slicing object is of type VMR!) as a mask to the GLM in a way that, for all maps in the GLM object, voxels where the VMR data is below the visibility threshold will be set to 0
 +  * **Export to Nifti** - exports the current GLM object as a [[xff - NII format|Nifti file]] without reslicing
  
 ===== VMP menu ===== ===== VMP menu =====
Line 75: Line 103:
   * **Mask with VMR** - applies the currently selected VMR (and thus only works if the selected slicing object is of type VMR!) as a mask to the ''​Maps''​ in the VMP, so that voxels where the VMR data is below the visibility threshold will be set to 0   * **Mask with VMR** - applies the currently selected VMR (and thus only works if the selected slicing object is of type VMR!) as a mask to the ''​Maps''​ in the VMP, so that voxels where the VMR data is below the visibility threshold will be set to 0
   * **Mask with VOI clusters** - applies the currently selected clusters from the list of all clusters (VOIs) as a mask, so that all voxels that are not covered by any of the selected clusters will be set to 0   * **Mask with VOI clusters** - applies the currently selected clusters from the list of all clusters (VOIs) as a mask, so that all voxels that are not covered by any of the selected clusters will be set to 0
 +  * **Export to Nifti** - exports the current VMP object as a [[xff - NII format|Nifti file]] without reslicing
  
 ===== SRF menu ===== ===== SRF menu =====
Line 86: Line 115:
  
   * **Toggle oblique slicing** - if selected, this will set (or revert) the spatial vectors (data extension directions) of the currently selected HDR object to be oblique with the main coordinate axes (L/R, A/P, S/I)   * **Toggle oblique slicing** - if selected, this will set (or revert) the spatial vectors (data extension directions) of the currently selected HDR object to be oblique with the main coordinate axes (L/R, A/P, S/I)
 +
 +===== Statistics menu =====
 +**//This menu is only visible when the GUI is in [[NeuroElf GUI#​minimized_mode|minimized mode]]!//**
 +  * **Close OBJ** - closes (unloads) the currently selected voxel-based or surface-based statistical object (if the object was created by the GUI during the current session, the object will also be cleared and its memory freed)
 +  * **Map properties** - invokes the map properties edit dialog (**only visible when exactly one map of a VMP object is selected**)
 +  * **Compute formula** - invokes the [[vmp.ComputeFormula|AFT::​ComputeFormula]] interface (**only visible when a HDR/​HEAD/​VMP object is selected**)
 +  * **Clustertable** - emulates a click on the (voxel and/or surface based!) Clustertable button and prints out the table in the console window
 +  * **Create SMP from selected maps** - emulates a click on the SMP-creation button (only for HDR/​HEAD/​VMP objects)
 +  * **Switch to stats object** - a sub-menu populated with a list of currently loaded voxel-based/​matching surface-based statistics objects
 +  * **Select map** - a (list of) sub-menu(s) populated with a list of the map names of the currently selected statistics object (with selected maps being checked)
 +  * **Multi-select maps** - opens a listbox dialog that allows to select multiple maps
 +  * **Select CONDITION for all subjects** - allows to copy map selection of one subject across subjects (**only visible when a RFX-GLM object is selected**)
 +  * **Delete selected maps** - deletes the selected maps
  
 ===== Analysis menu ===== ===== Analysis menu =====
Line 92: Line 134:
   * **Single-level RFX mediation** - this will open up the [[neuroelf_gui - RFX mediation|RFX mediation UI]] (which requires at least one RFX-GLM to be loaded; if several RFX-GLMs are loaded, the user can choose between these in the UI)   * **Single-level RFX mediation** - this will open up the [[neuroelf_gui - RFX mediation|RFX mediation UI]] (which requires at least one RFX-GLM to be loaded; if several RFX-GLMs are loaded, the user can choose between these in the UI)
   * **ECG Heart-rate data analysis** - this will open up the [[neuroelf_gui - ECG/GSR data analysis|ECG/​GSR data analysis UI]]   * **ECG Heart-rate data analysis** - this will open up the [[neuroelf_gui - ECG/GSR data analysis|ECG/​GSR data analysis UI]]
 +  * **Meta Analysis** - this will open up the [[neuroelf_gui - MKDA UI|Multi-level Kernel Density Analysis (MKDA) UI]]
  
 ===== Visualization menu ===== ===== Visualization menu =====
Line 98: Line 141:
   * **Create VOI condition plots** - this function requires clusters (VOIs) to be defined in the main UI window, for which functional data will be extracted and averaged according to conditions; first, the user will be asked to select an [[xff - MDM format|MDM file]] (which must be [[xff - PRT format|PRT]]-based!),​ after which the protocol (PRT) files will be read and the list of conditions to be available in subsequent plots will be presented in a listbox dialog (''​listdlg''​) for selection; following data extraction and computation,​ the [[neuroelf_gui - MDM VOI condition average UI|MDM VOI condition average plot]] window will open   * **Create VOI condition plots** - this function requires clusters (VOIs) to be defined in the main UI window, for which functional data will be extracted and averaged according to conditions; first, the user will be asked to select an [[xff - MDM format|MDM file]] (which must be [[xff - PRT format|PRT]]-based!),​ after which the protocol (PRT) files will be read and the list of conditions to be available in subsequent plots will be presented in a listbox dialog (''​listdlg''​) for selection; following data extraction and computation,​ the [[neuroelf_gui - MDM VOI condition average UI|MDM VOI condition average plot]] window will open
   * **Reload VOI condition plots** - as part of the [[neuroelf_gui - MDM VOI condition average UI|MDM VOI condition average UI]], once extracted data can be saved into a MAT file, which can then be reloaded at a later time (without having to re-extract and possibly regress the data), which is usually much more time efficient   * **Reload VOI condition plots** - as part of the [[neuroelf_gui - MDM VOI condition average UI|MDM VOI condition average UI]], once extracted data can be saved into a MAT file, which can then be reloaded at a later time (without having to re-extract and possibly regress the data), which is usually much more time efficient
 +
 +===== VOI menu =====
 +**//This menu is only visible when the GUI is in [[NeuroElf GUI#​minimized_mode|minimized mode]]!//**
 +  * **Go to nearest cluster (peak)** - sets the cursor position to the nearest peak in the list of VOIs (first voxel for each VOI)
 +  * **Select cluster...** - a (list of) sub-menu(s) populated with the names of the VOIs found in the cluster table list
  
 ===== Tools menu ===== ===== Tools menu =====
neuroelf_gui_-_menu_tree.1302742428.txt.gz · Last modified: 2011/04/14 02:53 by jochen